Beaver Lake Fix!

Discussion in 'Stillwater' started by sportsman, Feb 6, 2009.

  1. Between ongoing back problems and work I realized that it's been 4 months since last getting a line wet. Got a 'hall' pass today and fished Beaver from 11:00 to 2:00. No one on the lake but a few guys fishing at the park, thankfully LAWNT was not to be heard! No action until I reached the shallow spot in the middle of the lake, then got a few lazy tugs, no surprise with the water temp at 39 degrees. Decided to change tactics by just casting and stripping in with a quick and erratic action: right away the first one hit, but it came off. Next couple hours I released 5 with several more hits and a few LDR's. Pretty good fights with all the fish, nice size too: 20-22" or so. Deepest part of the lake I got any hits was 10', just worked the weedbeds and casting to shore by the trees. Only fly used was a size 10 GB Simi Seal leech[rust color]. Just getting out was a bonus, but the action made it a great day! If your going to fish it in a tube, wear an extra pair of socks!
     
  2. You did way better than I did Sportsman. The Beaver was tough on me today. Zippo-nada. I tried leeches, buggers, chironomids, san juan worms. I fished from 12:30-4:00 and all I got was cold!!!:(
     
  3. Where's Beaver Lake?
     
  4. Just east of Lake Samamish
     
  5. The sammamish plateu. That lake is a bitch in my opinion. Good to see that someone is pulling out those broods that no one has been able to catch in months.
     
  6. Good report Fred. Glad to hear you were able to get away. The dog and I took my mountain bike 5 or 6 miles up the John Wayne Trail Saturday and then stopped at the Rattlesnake launch to watch for rises before turning back for home about noon. A couple of big splats that rippled out across the mirror surface really put me in the mood. Let's get out together soon.

    K
     
  7. Went out again on Thursday...sunny skies made me think I should try something different, big mistake. Went back to the same fly and landed two. Only brought my Rio Aqualux, another mistake, 'cause I believe the fish were deeper this time..never saw a rise the whole time even with a modest hatch coming off.
     

Share This Page